Select Menu
» » » » » » Excel - Como colocar comentários nas suas fórmulas ou funções - Função N
«
Proxima
Postagem mais recente
»
Anterior
Postagem mais antiga


Olá seguidor e seguidora do blog!

Em mais um artigo vou explicar como utilizar a função N no Excel. 

Ela pode ser utilizada para fazer comentários em suas fórmulas e funções. Um recurso pouco documentado ou divulgado.

Antes de montar a solução, deixe-me falar o que a função N faz...

Ela foi criada para retornar um valor em número. Valor pode ser: número, texto, valores booleanos e erros.

Na tabela abaixo, você verá quais são seus tipos de retorno (de acordo com a documentação fornecida pelo próprio Excel).

Em um exemplo prático, poderíamos utilizar essa função para testar o valor de retorno de uma expressão, função ou fórmula.

Mas, o objetivo deste artigo é outro, vou mostrar com exemplos como você pode utilizar essa função para comentar seus códigos. 

Imagine uma fórmula bem simples. Gostaria de fazer a somatória de dois valores mas, gostaria de comentar porque estou fazendo a operação. Em um futuro, eu ou outra pessoa podemos dar manutenção na planilha e simplesmente não lembrar porque criamos o cálculo.

Exemplo:


A fórmula acima não apresenta o comentário, mas o print abaixo faz uso do comentário com a função N.

Fórmula: 

=SOMA(C6:C7)+N("Valor A e B referem-se à indicadores de produção")

Como você pôde perceber, a inclusão da função N na fórmula não causou alterações pois, conforme vimos na aplicação do uso da função, quando o conteúdo é um texto (outros na tabela), a função retorna 0 (zero). Zero somado ao valor anterior da operação não muda o seu resultado 😉.

Se você quiser utilizá-la também em uma função que retorna texto, é possível, mas tome cuidado pois o resultado da função N retorna 0 (zero) para textos e isso pode influenciar no resultado. 

Observe abaixo outro exemplo.

Fórmula:

=SE(C10>0;"POSITIVO";SE(C10=0;"ZERO";"NEGATIVO"))

Se colocarmos a função N no final desta função SE, ao invéz de utilizar o operador de soma (+), devemos utilizar o operador & (concatenar).


Fórmula:

=SE(C10>0;
        "POSITIVO";
        SE(C10=0;"ZERO";"NEGATIVO")
) & N("Testa se um número é positivo, negativo ou zero")

Podemos contornar esse problema utilizando a função Substituir...

= SUBSTITUIR(
                        SE(C10>0;
                             "POSITIVO";
                             SE(C10=0;"ZERO";"NEGATIVO")
                            
                              N("Testa se um número é positivo, negativo ou zero");
                     "0";
                     ""
                     )

E outras funções ainda podem ser utilizadas. Mas, vamos focar no problema...

Para evitar que isso aconteça, podemos colocar no início da função SE, no teste lógico o comentário, assim o valor 0 (zero) será somado à condição, não atrapalhando sua dinâmica.


Fórmula:

=SE(N("Testa se um número é positivo, negativo ou zero") + C10>0;
        "POSITIVO";
        SE(C10=0;"ZERO";"NEGATIVO")
       )

Agora me responda nos comentários: já conhecia esse recurso no Excel?

Até o próximo artigo!


Alessandro Trovato
Compartilhando conhecimento, sempre!



E, muito em breve um novo curso em minha plataforma... 











#excel #funçõesExcel #officescript #excelonline #excelscript #trovato #mvp #mvpbr #cursostrovato #funçãoN


Autor Alessandro Trovato

Esta é uma breve descrição no bloco de autor sobre o autor. Você edita-lo, no html
«
Proxima
Postagem mais recente
»
Anterior
Postagem mais antiga

Nenhum comentário

Comentarios